Instructions for assembling the
MAG-BOARD and build MAGRA
gradiometer

Version 1.2
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Assembling the MAG-BOARD

If you have already purchased the assembled MAG-BOARD, you can skip this chapter.

Although most of the components are already soldered to your MAG-BOARD, you still need
to solder the power cord, connectors and the buzzer.

It is very important not to mix the colors of the power cord - black cable must be on the left
»-«, red cable on the right »+« side.

The cables on the sensors must be routed correctly. See captions
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You can connect up to 3 buttons and 2 LEDs onto your MAG-BOARD. The current program
version has the NULLing button, »+« and »-« for sensitivity. Connect them as follows
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LCD VOLTAGE SELECT:
If you buy LCD with MAG-BORD, you do not have to do anything. If using a 3.3V LCD screen,
you have to cut the jumper and make contact with a drop of tin on the 3.3V voltage side.

° LCD “VOLTAGE
SELECT

TA 43v04-
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EXTERNAL FLASH
MAG-BOARD has an option of storing data to an external flash drive, which the user has to
tin by himself. W25Q32JVSS is suggested, but others may also be used.
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Programming

MAG-BOARD is already equipped with a preloaded program for the gradiometer. If you do
not need to create your own program, this chapter can be skipped.

In case you wish to adapt the program according to your needs, use the source code for the
arduino, which is available at www.fgsensors.com. Attention! Open-source program for the
gradiometer on the website does not support connection to the »FG sensors app« android
application!

MicroUSB cable and Arduino IDE program is required for programming process
(www.arduino.cc/en/software)
For installing you will need to download a package for ESP32. To do this, input

https://dl.espressif.com/d|/package_esp32_index.json in the field Additional Boards

Manager URLs under File -> Preferences tab

Editor language: English (English) ~ | (requires restart of Arduino)
Editor font size: 12

Interface scale: Automatic | 100 - [% (requires restart of Arduing)

Theme: Default theme - | (requires restart of Arduino)

Show verbose output during: [ | compilation [ | upload

Compiler warnings: None  «

[] Display line numbers [[] Enable Code Folding

verify code after upload [] use external editor

Check for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager URLs: |https:ffdl.espressif.com,‘dlfpackage_esp32_inde:(.json ﬁ
Mare preferences can be edited directly in the file
C:\Usersmimie\Documents\ArduinoData\preferences. txt

{edit only when Arduino is not running)

CK Cancel

Install the board by selecting the menu Tools -> Board -> Board Manager...

:r@ mag-board | Arduino 1.8.13
\File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload

mag-board §

Manage Libraries.., Ctrl+5hift+|
Serial Monitor Cir+ShifteM |
Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

-
Board: "Arduino Uno" J Boards Manager...

Port 1 Arduine Yiin
Get Board Info &  Arduino Uno

Programmer. "AVRISP mKkIl" Arduino Duemilanove or Diecimila

Burn Beotloader Arduino Nano

Arduine Mega or Mega 2560

' %
+ #include "soc
'

Input »esp32« and install it
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http://www.fgsensors.com
https://dl.espressif.com/dl/package_esp32_index.json

Type |l

@ Boards Manager

v |3

esp32

by Espressif Systems

Boards included in this package:

ESP32 Dev Module, WEMOS Lolin32, WEMOS D1 MINI ESP32.
More Info

Close:

Next, click on the installed board. Select Tools -> Board:
Module

f@ mag-board | Arduino 1.8.13
\File Edit Sketch Toels Help

mag-board §

#include

#include

#include

$include
#include

#include ™

#include ™

<WiF

"dri

Soc

Auto Format

Archive Sketch

Fix Encoding & Relead
Manage Libraries...
Serial Monitor

Serial Plotter

WiFi101 / WiFiNIMNA Firmware Updater
‘Board: "Arduino Uno”

Port

Get Beard Info

Programmer: "AVRISP mikll"

Burn Bootloader

Ctrl+T

Ctrl+Shift+]
Ctrl+Shift+M
Ctrl+5hift+L

Boards Manager... ‘

-> ESP32 Arduino choose ESP32 Dev

Arduino AVR Boards
ESP32 Arduino

&
ESP32 Dev Module
E5P32 Wrover Medule
ESP32 Pico Kit
TinyPICO

After selecting the board, click on Tools and select Port. Which port you choose, depends on
your PC. | will choose COM4.
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E‘@ mag-board | Arduine 1,813

\File Edit Sketch

mag-board §

<WiF
"std
"dri

#include
#include
#include
#¢include
#include
#include
#includse

"dri]
"o
soc
"soC]

#define LCD O

fdefine LCD I

#define I2C 5
#include <Wir
#include <Lig
LiguidCrystal

gifdef LCD T2
#define I2C 5

Toels Help
Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+ Shift+|
Serial Monitor Ctrl+ Shift+M
Serial Plotter Ctrl+5Shift+L

WIFiI101 / WIiFINIMNA Firmware Updater

Board: "ESP32 Dev Module” >

Upload Speed: "921600" b

CPU Frequency: "240MHz (WiFi/BT)" *

Flash Frequency: "80MHz" 2

Flash Mode: "QIO" >

Flash Size: "4MB (32Mb)" »

Partition Scheme: "Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS)" )

Core Debug Level: "Mone” »

PSRAM: "Disabled" >

Port 2 Serial ports
Get Board Info COM1
Programmer bl

Burn Bootloader

Now you have to install a library for the 12C LCD and buzzer. To do this, select menu Sketch
->Include Library -> Manage Libraries...

:@ mag-board |

Arduine 1.8.13

(File Edit Sketch Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+U
Upload Using Programmer  Ctrl+Shift+U
E Export compiled Binary Ctrl+ Alt+5
E Show Sketch Folder Ctrl+ K L Wi . £JSENS0rS. £0
o includetibrey :
" AddFile.. et
E #include <WiFi.h> Add ZIP Library...
! #include "stdioc.h”
! #include "driver/ledc.h™ Arduino libraries
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input »liquidcrystal_pcf8574« and install it

@ Library Manager

Type Al w | Topic [ | fl-i-ciﬁ-it‘;laysta.l_pcﬁaf;?*%

LiquidCrystal_PCFEB574
by Matthias Hertel
A library for driving LiquidCrystal displays (LCD) by using the I2C bus and an PCF8574 12C adapter. This library uses the

original Wire library for communication.
More info

'Version 1.3..0 £

LiquidCrystallO
by Arduing, Adafruit, theCodersCorner

LiquidCrystal fork for displays based on HD44780. Uses the I0Abstraction library to work with i2c, PCF8574, MCP22017, Shift
registers, Arduino pins and ports interchangably. Forked version LiquidCrystal to work with I2C backpacks, PCFE374,

MCP232017, shift registers, ports and arduino pins. Compatible with most Hitachi HD44780 chipsets on text-based LCDs. The
library works in 4 bit, 8 bit or PORT mode.

Mors info

Afterwards search for »easybuzzer« and install it

@ Library Manager

Type Al « | Topic | Al w | |easybuzzer|
EasyBuzzer ~
by Evert Arias
EasyBuzzer Library A library to easily make beeps with a Buzzer.
More info
Version 1.0.4 Install
L

Close

This is all there is to it. For uploading simply press the »upload« key.
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Programming with BIN file

To download the official codes (new FW), the process is simple.

First download »Offical Firmware(BIN)« from our webpage. For upload it you need free tool
»flash downolad tool« downloaded from site:
https://www.espressif.com/en/support/download/other-tools

After run select chipType »ESP32« and click OK

B DOWN... -

chipType: ESp32

werkMode: develop

loadMode: uart

0K

After this:

1. Click where »...« are and select downloaded mag-board bineary file
2. Mark »« to comform this line

3. Put address at 0x10000

4. Select COM port (in my case is COM4 you may have some other!)

5. Select BAUD to 921600

6. Click to START
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https://www.espressif.com/en/support/download/other-tools

B ESP32 DOWNLOAD TOOL V3.9.0

d: | HSPIDawnload

duincmag-board\mag-beard.ine.esp32.bin .. @ | 010000

U - |@

U - |@

O - @

g - |@

O - @

O - |@

O o @ w
SpiFlashConfig

SPI SPEED SPI MODE DETECTED INFO
® 40MHz Oaio [] DoNetChgBin

O267MHz O QouT LOCK SETTINGS

() 20MHz ®DIO
O 80MHz O pout
(O FASTRD

CombineBin

Default

Download Panel 1

START STOP ERASE comd

BAUD: [a21600 v

Assembling the MAGRA gradiometer
To assemble the MAGRA you need:

- MAGRA kit, which can be ordered here: www.fgsensors.com. Or you can print the
parts on a 3D printer from the STL file, available on our website.

- Waste water tube of 35-36mm diameter (depends on your local shop) and 1m length
(or longer if needed)

- Tube cap of 35-36mm diameter (depends on your local shop)

- Drills of @3mm, @6.5mm, @10mm and drilling machine

ATTACHING THE CONTROL UNIT

First, attach the electronics housing onto the bracket. Holes for @3mm screws and @10mm
cables must be drilled in the housing. The easiest way to do this is to set the bracket onto the
housing and mark the holes.
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http://www.fgsensors.com

Take the holder of the upper sensor and push the sensor into it to the point where it passes
the latch.

Then connect the sensor with a shorter cable supplied and secure it with some hot glue.

Drill 3 holes in the plug of approx. @ 6.5 -7 mm in diameter, to allow rotation of the sensor

adapter screws. You can also use a gadget printed on a piece of paper (PDF in 1:1 scale can
be found on our website)
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Insert the sensor into the holder. Put the supplied screws through the holes and tighten
them so that the sensor is fixed in the center. Put the assembly onto the plug, allowing
access through drilled holes and fix the bracket with some hot glue.

Connect the lower sensor with a longer cable supplied and secure it with some hot glue. Pull
the cable through the tube and insert the upper sensor from the top side, approximately
10cm below the top and secure it with hot glue, so the sensor does not move. Both sensors
must be oriented in same way. Upside down!

When the glue is dried, insert the lower sensor into the tube to the extent, which still allows
the screws to be turned. Lubricate the seal on the tube beforehand with liquid soap or hand
cream for easy insertion and turning.
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Calibration of MAGRA gradiometer

For calibration of the gradiometer you need a plastic or other non-metallic screwdriver,
assembled and working MAG-BOARD and a non-metallic bracket (V-block) allowing rotation
of the gradiometer without moving. The bracket can be printed (STL files available on our
site) or bought in our webshop.

ATTENTION! The calibration process must be performed in a room with no electromagnetic
(electrical wiring, transformers, speakers, etc.) sources, iron and magnetic objects nearby.

Place the V-blocks horizontally onto the level surface in the east-west position and put the
gradiometer on it. Connect the LCD and the sensors and turn the MAG-BOARD on. If
everything is OK, a 5-6 digit number will appear on the screen next to the »U«(upper sensor)
and »L« (lower sensor). If the screen is blank, use the screwdriver to turn the blue element
on the black board next to the LCD to left/right. This is a potentiometer for adjusting the
screen contrast.

1. Rotate the tube around its axis and observe both numbers. Numbers are increasing
and decreasing.

2. By only turning the cap you need to achieve both numbers (»L« and »U«) to increase
and decrease simultaneously.

After finishing this phase, you are ready to perform fine tuning.

3. Press the NULL button on the electronic part (or android app) and observe the
number under letter »D« on the screen while rotating the tube around its axis.

4. When the highest value is reached, loosen the bottom screw and tighten the upper
screw (if there is no bottom screw, loosen two of the closest ones). All screws must
always be slightly tightened. When making last corrections, you do not have to loosen
the bottom screws, but only tighten the upper one.

5. Repeat the steps from the 3rd point onwards, until you reach the slightest change in
the value »D« per revolution
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6. If the value below 1000 can not be reached, slightly rotate the cap as in the 2nd point
and repeat the tuning process as explained in the 3rd point.

This step is very time consuming, but very important for proper functioning.

After successfully finishing the tuning process, check if any screw protrude the cap. If yes,
please remove the protruding part. Attention! This can put the gradiometer out of tune. We
suggest the protruding part to be sanded off and not cut off with a knife or saw! Then pour
the hot glue over the screws and push it all the way into the tube.

Next is the installation of electronics onto the tube. You need to add hot glue to the
dedicated channels and push it into the tube.

Screw the housing onto the bracket. Attach the LCD holder to the housing, and pull the

sensor wires through the hole.
F

Attach the circuit and LCD and connect it with cables. Pay attention to how the cables are
turned. Your cables may deviate in color. The important thing is that the beginning and the
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end are in the same position.
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NOTE:

Given that it is left to the self-builder to handle the components, which can lead to their
destruction or malfunction of the board, no guarantee can be given for the correct function
of the assembled MAG-BOARD/MAGRA. However, online assembly assistance will be
provided and any justified complaints will be carefully treated.
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